Uploaded image for project: 'OpenVZ'
  1. OpenVZ
  2. OVZ-3965

IPv6 down with debian lenny as VE

    Details

    • Type: Bug
    • Status: Closed
    • Priority: Major
    • Resolution: Fixed
    • Fix Version/s: OpenVZ-legacy
    • Component/s: Containers::Userspace
    • Security Level: Public
    • Environment:
      Operating System: Debian
      Platform: x86_64 (AMD64)

      Description

      I use a prefix like 2002:xxxx:xxxx:22:: and each VE receives an address by this rule 2002:xxxx:xxxx:22:<VEID>::1.

       Since an upgrade in debian lenny. Ipv6 ip configuration look like break.
      I try to setup ipv6 with my outdated lenny template, it's working very well. But after upgrade and restart the ve, the problem come back.

       To get ipv6 service back on lenny i just add /0 for the ifconfig command in the debian script. See patch attached.

      ( kernel version : 2.6.18-028stab053 | vzctl version : vzctl version 3.0.22 )

      Mathieu

        Issue Links

          Activity

          Hide
          dev@openvz.org Kirill Korotaev added a comment -

          Mathieu, have you forgot to attach the patch?

          Show
          dev@openvz.org Kirill Korotaev added a comment - Mathieu, have you forgot to attach the patch?
          Hide
          mathgl@freesurf.fr mathgl added a comment -

          Attachment debian_lenny_ipv6.diff has been added with description: my patch

          Show
          mathgl@freesurf.fr mathgl added a comment - Attachment debian_lenny_ipv6.diff has been added with description: my patch
          Hide
          mathgl@freesurf.fr mathgl added a comment -

          Sorry, i was sure it was be done at the creation of the bug.

          Mathieu.

          Show
          mathgl@freesurf.fr mathgl added a comment - Sorry, i was sure it was be done at the creation of the bug. Mathieu.
          Hide
          kir Kir Kolyshkin added a comment -

          There's a Debian bug for this issue:
          http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505792

          Show
          kir Kir Kolyshkin added a comment - There's a Debian bug for this issue: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=505792
          Hide
          kir Kir Kolyshkin added a comment -
          Show
          kir Kir Kolyshkin added a comment - Fixed in GIT http://git.openvz.org/?p=vzctl;a=commit;h=9fe02f4a9a42d8d608c401d2508da01f2a07a13e Will be available in vzctl >= 3.0.24.
          Hide
          sergeyb Sergey Bronnikov added a comment -

          Bug was fixed more than one year ago and there were no complains from reporter after fix. We believe bug fix helped and mark bug as closed.

          Show
          sergeyb Sergey Bronnikov added a comment - Bug was fixed more than one year ago and there were no complains from reporter after fix. We believe bug fix helped and mark bug as closed.

            People

            • Assignee:
              kir Kir Kolyshkin
              Reporter:
              mathgl@freesurf.fr mathgl
            • Votes:
              0 Vote for this issue
              Watchers:
              5 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: